Conditions préalables pour Snowpark

Scala

L’API de Snowpark est prise en charge avec Scala 2.12 (plus précisément, la version 2.12.9 et les versions ultérieures 2.12.x).

Note

Scala 2.13.x (une version plus récente de Scala) n’est pas pris en charge.

Si vous utilisez Scala 2.13.x, votre code risque de ne pas s’exécuter avec des erreurs java.lang.NoSuchMethodError et illegal cyclic inheritance involving trait Iterable / Map.

Java Virtual Machine (JVM) pour Scala

Pour les JVM utilisées avec Scala, Java 11 est la version recommandée.