Voraussetzungen für Snowpark

Scala

Die Snowpark-API unterstützt Scala 2.12 (insbesondere Version 2.12.9 und spätere 2.12.x-Versionen).

Bemerkung

Scala 2.13.x (eine neuere Version von Scala) wird nicht unterstützt.

Wenn Sie Scala 2.13.x verwenden, wird die Ausführung Ihres Codes möglicherweise mit den Fehlern java.lang.NoSuchMethodError und illegal cyclic inheritance involving trait Iterable / Map verhindert.

Java Virtual Machine (JVM) für Scala

Für die JVM, die mit Scala verwendet wird, wird Java-Version 11 empfohlen.