Configuration de Visual Studio Code pour Snowpark

Cette rubrique explique comment configurer Visual Studio Code pour Snowpark.

Dans ce chapitre :

Configuration de Visual Studio Code pour le développement Scala

Pour faciliter l’écriture de code Scala dans Visual Studio Code, installez l’extension Metals. L’extension Metals fournit le remplissage automatique de code, des indications sur les paramètres et des informations sur les types et les méthodes.

Pour installer l’extension Metals :

  1. Dans Activity Bar sur le côté gauche de la fenêtre, cliquez sur l’icône Extensions.

    Extensions icon in the Activity Bar in Visual Studio Code

    (Si Activity Bar n’est pas affiché, assurez-vous que View » Appearance » Show Activity Bar est coché).

    Cela affiche la vue Extensions, qui vous permet de parcourir et d’installer des extensions à partir du marché des extensions.

  2. Dans le champ de recherche de Search Extensions in Marketplace, recherchez le terme :

    metals
    
  3. Dans les résultats de la recherche, trouvez l’extension Scala (Metals), et cliquez sur Install.

Pour plus d’informations sur l’extension Scala (Metals), voir Visual Studio Code dans la documentation Metals.

Création d’un nouveau projet Scala dans Visual Studio Code

Ensuite, créez un nouveau projet Scala pour Snowpark.

  1. Créez un répertoire d’espace de travail pour vos projets. Par exemple :

    mkdir snowpark_projects
    

    Ce répertoire contiendra des sous-répertoires pour les projets que vous créez.

  2. Dans Visual Studio Code, choisissez File » Open, sélectionnez le répertoire que vous avez créé, et cliquez sur Open.

  3. Dans Activity Bar sur le côté gauche, cliquez sur l’icône Metals.

    Metals extension icon in the Activity Bar in Visual Studio Code
  4. Sous Packages dans Side Bar (à droite de Activity Bar), cliquez sur le bouton New Scala Project.

    Button to create a new Scala project Visual Studio Code
  5. Sélectionnez un modèle à utiliser pour le nouveau projet (par exemple, scala/hello-world.g8).

  6. Sélectionnez le répertoire de l’espace de travail que vous avez créé précédemment (snowpark_projects), et cliquez sur Ok.

  7. Saisissez un nom pour le nouveau projet (par ex. hello_snowpark).

  8. Lorsque la boîte de dialogue située dans le coin inférieur droit de la fenêtre vous y invite, cliquez sur Yes pour ouvrir le nouveau projet dans une nouvelle fenêtre.

    Dialog box prompting you to open the new project in a new window
  9. Lorsque la boîte de dialogue située dans le coin inférieur droit de la fenêtre vous y invite, cliquez sur Import build pour importer le build.

    Dialog box prompting you to import the build for the new project

Configuration du projet Visual Studio Code pour Snowpark

Ensuite, configurez le projet pour Snowpark.

  1. Dans Activity Bar sur le côté gauche de la fenêtre, assurez-vous que l’icône Explorer (la première icône en haut) est sélectionnée.

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Sous Explorer dans Side Bar (à droite de Activity Bar), sous votre projet, sélectionnez le fichier build.sbt à éditer.

    Selecting the build.sbt file for editing

    Dans le fichier build.sbt de votre projet, apportez les modifications suivantes :

    1. Si le paramètre scalaVersion ne correspond pas à la version que vous prévoyez d’utiliser, mettez-le à jour. Par exemple :

      scalaVersion := "2.12.13"
      

      Notez que vous devez utiliser une version de Scala qui est prise en charge pour l’utilisation de la bibliothèque Snowpark.

    2. Ajoutez le référentiel de la version OSGEO à la liste des résolveurs, et ajoutez la bibliothèque Snowpark à la liste des dépendances. Par exemple :

      resolvers += "OSGeo Release Repository" at "https://repo.osgeo.org/repository/release/"
      libraryDependencies += "com.snowflake" % "snowpark" % "0.6.0"
  3. Après avoir effectué ces modifications, choisissez File » Save pour enregistrer vos modifications.

  4. Lorsque la boîte de dialogue située dans le coin inférieur droit de la fenêtre vous y invite, cliquez sur Import changes pour réimporter le fichier.

    Dialog box prompting you to re-import the build.sbt file

Vérification de la configuration de votre projet Visual Studio Code

Pour vérifier que vous avez configuré votre projet pour utiliser Snowpark, exécutez un exemple simple de code Snowpark.

  1. Dans Activity Bar sur le côté gauche de la fenêtre, assurez-vous que l’icône Explorer (la première icône en haut) est sélectionnée.

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Sous Explorer dans Side Bar, sous votre projet, développez le dossier src/main/scala, et sélectionnez et ouvrez le fichier Main.scala.

  3. Dans le fichier Main.scala , remplacez le contenu par le code ci-dessous :

    import com.snowflake.snowpark._
    import com.snowflake.snowpark.functions._
    
    object Main {
      def main(args: Array[String]): Unit = {
        // Replace the <placeholders> below.
        val configs = Map (
          "URL" -> "https://<account_identifier>.snowflakecomputing.com:443",
          "USER" -> "<user name>",
          "PASSWORD" -> "<password>",
          "ROLE" -> "<role name>",
          "WAREHOUSE" -> "<warehouse name>",
          "DB" -> "<database name>",
          "SCHEMA" -> "<schema name>"
        )
        val session = Session.builder.configs(configs).create
        session.sql("show tables").show()
      }
    }
    

    Remarques :

    • Remplacez les <espaces réservés> par les valeurs que vous utilisez pour vous connecter à Snowflake.

    • Pour <identificateur_de_compte>, indiquez votre identificateur de compte.

    • Si vous préférez utiliser l’authentification par paire de clés :

      • Remplacez PASSWORD par PRIVATE_KEY_FILE et indiquez le chemin d’accès à votre fichier de clé privée.

      • Si la clé privée est cryptée, vous devez définir PRIVATE_KEY_FILE_PWD comme étant la phrase secrète pour le décryptage de la clé privée.

      Au lieu de définir PRIVATE_KEY_FILE, vous pouvez définir la propriété PRIVATEKEY sur la valeur de la clé privée du fichier de clé privée. Notez que vous devez supprimer les lignes -----BEGIN ... PRIVATE KEY----- et -----END ... PRIVATE KEY----- ainsi que les retours chariot et les sauts de ligne.

    • Si vous prévoyez de créer des UDFs :

  4. Cliquez sur run au-dessus de la ligne Object pour exécuter l’exemple.

Si le message d’erreur suivant apparaît :

Run session not started

vérifiez l’onglet Problems en bas de la fenêtre. Si cet onglet n’apparaît pas dans le bas de la fenêtre, sélectionnez l’élément View > Problems dans le menu.