Veraltete Features

Die folgenden Snowflake-Features und Betriebssysteme/Programmiersprachen sind veraltet oder werden demnächst veraltet sein:

Geplantes Veralten

Aktueller Status

Funktionsbereich

Beschreibung

Zusätzliche Anmerkungen

Oktober 2023

Ausstehend

Ökosystem

Gemäß der Snowflake-Support-Richtlinie werden alle Clientversionen, die niedriger als die folgenden sind, ab dem 31. Oktober 2023 nicht mehr unterstützt:

  • SnowSQL 1.2.20

  • Python-Konnektor 2.7.0

  • SQLAlchemy (für Python) 1.3.2

  • JDBC-Treiber 3.13.10

  • ODBC-Treiber 2.24.2

  • Node.JS-Treiber 1.6.4

  • Go-Treiber 1.6.3

  • .NET-Treiber 2.0.7

  • PHP-PDO-Treiber 1.2.0

  • Kafka-Konnektor 1.6.0

  • Spark-Konnektor 2.9.1

Die neuesten Versionen aller Clients, mit Ausnahme von SnowSQL und dem ODBC-Treiber, können Sie unter Treiber und Bibliotheken herunterladen.

Die neueste Version von SnowSQL können Sie über den SnowSQL-Download herunterladen.

Die neueste Version des ODBC-Treibers können Sie über den ODBC-Download herunterladen.

Juli 2023

Veraltet am 31. Januar 2023

Ökosystem

Gemäß der Snowflake-Support-Richtlinie werden alle Clientversionen, die niedriger als die folgenden sind, ab dem 31. Juli 2023 nicht mehr unterstützt:

  • SnowSQL 1.2.17

  • Python-Konnektor 2.5.0

  • SQLAlchemy (für Python) 1.2.5

  • JDBC-Treiber 3.13.6

  • ODBC-Treiber 2.23.3

  • Node.JS-Treiber 1.6.2

  • Go-Treiber 1.6.0

  • .NET-Treiber 2.0.4

  • PHP-PDO-Treiber 1.1.0

  • Kafka-Konnektor 1.6.0

  • Spark-Konnektor 2.9.1

April 2023

Veraltet am 30. April 2023

Ökosystem

Gemäß der Snowflake-Support-Richtlinie werden alle Clientversionen, die niedriger als die folgenden sind, seit dem 30. April 2023 nicht mehr unterstützt:

  • SnowSQL 1.2.14

  • Python-Konnektor 2.4.3

  • SQLAlchemy (für Python) 1.2.5

  • JDBC-Treiber 3.13.1

  • ODBC-Treiber 2.23.2

  • Node.JS-Treiber 1.6.1:

  • Go Driver 1.4.3

  • .NET-Treiber 2.0.0

  • PHP-PDO-Treiber 1.0.2

  • Kafka-Konnektor 1.5.3

  • Spark-Konnektor 2.8

Januar 2023

Veraltet am 31. Januar 2023

Ökosystem

Gemäß der Snowflake-Support-Richtlinie werden alle Clientversionen, die niedriger als die folgenden sind, seit dem 31. Januar 2023 nicht mehr unterstützt:

  • SnowSQL 1.2.10

  • Python-Konnektor 2.3.9

  • SQLAlchemy (für Python) 1.2.4

  • JDBC-Treiber 3.12.17

  • ODBC-Treiber 2.22.4

  • Node.JS-Treiber 1.5.3

  • Go Driver 1.3.13

  • NET-Treiber 1.1.4

  • PHP-PDO-Treiber 1.0.1

  • Kafka-Konnektor 1.5.2

  • Spark-Konnektor 2.8.3

Oktober 2022

Veraltet im Oktober 2022 Ausstehend veraltet Januar 2023

SQL, Ökosystem, Sicherheit

Folgende Funktionen sind veraltet und werden nicht mehr unterstützt:

Verwenden Sie stattdessen die folgenden Funktionen:

Mai 2022

Veraltet ab 11./12. Mai 2022

SQL

Die folgenden Schlüsselwörter für den Befehl CREATE PROCEDURE sind veraltet:

  • IMMUTABLE

  • VOLATILE