Snowparkの前提条件

Scala

Snowpark API は、 Scala 2.12 (具体的には、バージョン2.12.9以降の2.12.xバージョン)でサポートされています。

注釈

Scala 2.13.x(Scalaの最新バージョン)は サポートされていません

Scala 2.13.xを使用する場合、コードは java.lang.NoSuchMethodError および illegal cyclic inheritance involving trait Iterable / Map エラーで実行に失敗する可能性があります。

Scala用Java仮想マシン(JVM)

Scalaで使用する JVM は、Java 11が推奨バージョンです。