Native Programmierschnittstellen

Das Snowflake-Ökosystem unterstützt die Entwicklung von Anwendungen mit vielen gängigen Programmiersprachen und Entwicklungsplattformen. Mithilfe der von Snowflake bereitgestellten nativen Clients (Konnektoren, Treiber usw.) können Sie Anwendungen mithilfe einer der folgenden Schnittstellen entwickeln:

Schnittstelle

Version / Installationsanforderungen

Anmerkungen

Go Language

Sprache Go: 1.14 (oder höher)

Snowflake: Go Snowflake Driver – Über die Go-Website verfügbar

JDBC

Java: 1.8 (oder höher)

Snowflake: JDBC-Treiber – Download über Maven

Microsoft .NET

Microsoft .NET: Visual Studio 2017

Snowflake: .NET-Treiber – Download von GitHub

Node.js

Node.js: 10.0 (oder höher)

Snowflake: Node.js-Treiber – Installation mit npm

ODBC

Sprache C: Anforderungen sind Betriebssystem-spezifisch

Snowflake: ODBC-Treiber – Download über das Snowflake Client Repository

PHP

PHP: 7.2 (oder höher)

Snowflake: PHP-PDO-Treiber – Build aus GitHub

Python language

Python: 3.6, 3.7, 3.8, or 3.9

Snowflake: Konnektor für Python – Installation mit pip

SQLAlchemy

Python: 3.6, 3.7 oder 3.8

SQLAlchemy: Keine Anforderungen

Snowflake: SQLAlchemy Toolkit – Installation mit pip