Aufgabenverlauf anzeigen

Aufgaben ermöglichen die planmäßige Ausführung von SQL-Code. Ein Directed Acyclic Graph (DAG) von Aufgaben führt SQL-Code aus, der in einer Stammaufgabe und einer Menge von untergeordneten Aufgaben definiert ist, die anhand ihrer Abhängigkeiten organisiert sind. Weitere Informationen zu Aufgaben finden Sie unter Einführung in Aufgaben.

In Snowsight können Sie den Aufgabenverlauf für Ihr gesamtes Konto einsehen. Sie können auch den Aufgabenverlauf für eine bestimmte Aufgabe untersuchen und Aufgaben als gerichtete azyklische Graphen (DAGs) anzeigen. Hinweis:

Task history data is only available if the task has been executed in the last 7 days.
Additionally, only a role that has the minimum required privileges to query the TASK_HISTORY table function can explore tasks in Snowsight.

Unter diesem Thema:

Task-Graph

Task-Graph stellen die Ausführung einer Stammaufgabe und untergeordneter Aufgaben im DAG-Format dar. Sie können die folgenden Aktionen mit Task-Graphen ausführen:

  • Anzeigen von Aufgabeninformationen, einschließlich des Status der Stammaufgabe und der ausgewählten untergeordneten Aufgabe.

  • Untersuchen von Task-Graphen, die von übergeordneten zu untergeordneten Aufgaben gezeichnet werden.

  • Auswahl der Aufgabenelemente für die Anzeige zusätzlicher Details.

Snowsight task graph example with annotations.

So zeigen Sie Task-Graphen an:

  1. Klicken Sie im Navigationsmenü von Snowsight auf Data » Databases.

  2. Navigieren Sie im rechten Fensterbereich mit dem Objekt-Explorer zu einer Datenbank und einem Schema.

  3. Erweitern Sie unter dem ausgewählten Schema den Eintrag Tasks.

  4. Wählen Sie eine Aufgabe aus. Es werden Informationen zur Aufgabe angezeigt sowie die Unterregisterkarten Task Details, Graph und Run History.

  5. Wählen Sie die Registerkarte Graph aus. Der Task-Graph wird als Hierarchie von untergeordneten Aufgaben angezeigt.

  6. Wählen Sie eine Aufgabe aus, um deren Details anzuzeigen.

Ausführungsverlauf

Der Ausführungsverlauf einer Aufgabe enthält Details über jede Ausführung einer bestimmten Aufgabe. Sie können die geplante Zeit, die tatsächliche Startzeit, die Dauer einer Aufgabe und andere Informationen einsehen.

Snowsight task history page with annotations for each section.

Zu jeder Instanz können die folgenden Informationen angezeigt werden:

  • Geplante Startzeit: Wann soll die Aufgabe das nächste Mal ausgeführt werden.

  • Status: Status der letzten Ausführung.

  • Dauer: Zeitdauer der letzten Ausführung in Sekunden.

  • Abfrage: Anzeige des Query Profile oder der Anweisungen der Aufgabe in einem Arbeitsblatt.

So zeigen Sie die Ausführungsverlauf an:

  1. Klicken Sie im Navigationsmenü von Snowsight auf Data » Databases.

  2. Navigieren Sie im rechten Fensterbereich mit dem Objekt-Explorer zu einer Datenbank und einem Schema.

  3. Erweitern Sie unter dem ausgewählten Schema den Eintrag Tasks.

  4. Wählen Sie eine Aufgabe aus. Es werden Informationen zur Aufgabe angezeigt sowie die Unterregisterkarten Task Details, Graph und Run History.

  5. Wählen Sie die Registerkarte Run History aus.

Aufgabenverlauf auf Kontoebene

Der Aufgabenverlauf zeigt Aufgabeninformationen auf Kontoebene an und ist in drei Bereiche unterteilt:

  • Auswahl (1) – Definiert den Umfang der anzuzeigenden Informationen des Aufgabenverlaufs, einschließlich Aufgabentypen, Datumsbereich und andere Informationen

  • Histogramm (2) – Zeigt ein Balkendiagramm mit den Aufgabenausführungen für den Task-Graphen an.

  • Aufgabenliste (3) – Zeigt eine Liste der ausgewählten Aufgaben an.

Snowsight task history page with annotations for each section.

So zeigen Sie den Aufgabenverlauf auf Kontoebene an:

  1. Klicken Sie im Navigationsmenü von Snowsight auf Activity » Task History. Der Bereich Task History zeigt alle Aufgaben und übersprungenen Aufgaben für den ausgewählten Datumsbereich an und enthält eine Anzeige nach Tag.

  2. Klicken Sie auf Date Range, und wählen Sie einen Datumsbereich von gestern bis in alle Zeiten aus oder einen kundenspezifischen Bereich, um die Aufgabenmenge einzuschränken oder zu erweitern.

  3. Klicken Sie auf Status, um nach Aufgabenstatus zu filtern, einschließlich: All (Alle), Succeeded (Erfolgreich), Failed (Fehlgeschlagen) oder Canceled (Abgebrochen).

  4. Klicken Sie auf Database, und wählen Sie eine Datenbank aus, um Aufgaben nach dieser Datenbank zu filtern.

  5. Klicken Sie auf Schema, um All auszuwählen, oder geben Sie einen Schemanamen ein, um nach diesem Schema zu filtern.

Das Histogramm zeigt eine nach Datum aufgeschlüsselte Liste von Aufgabenausführungen an, die in die Kategorien Succeeded (Erfolgreich), Failed (Fehlgeschlagen) oder Skipped (Übersprungen) unterteilt sind. Unterhalb des Histogramms wird eine Liste aller Aufgaben angezeigt.

Sie können Aufgabenlisten weiter verfeinern oder Aufgabendetails untersuchen:

  • Mit der Schaltfläche Search können Sie nach einer bestimmten Aufgabe in der Liste suchen.

  • Durch Auswahl eines Balkens im Histogramm wird nur der ausgewählte Bereich aufgelistet.

  • Klicken Sie auf eine beliebige Stelle in einer Aufgabenzeile, um Task Details, Graph oder Run History zu untersuchen.

Zurück zum Anfang