Einrichten von Visual Studio Code für Snowpark

Unter diesem Thema wird erklärt, wie Sie Visual Studio Code für Snowpark einrichten.

Unter diesem Thema:

Einrichten von Visual Studio Code für die Scala-Entwicklung

Um das Schreiben von Scala-Code in Visual Studio Code zu vereinfachen, installieren Sie die Metals-Erweiterung. Die Metals-Erweiterung bietet Codevervollständigung, Parameterhinweise und Informationen zu Typen und Methoden.

So installieren Sie die Metals-Erweiterung:

  1. Klicken Sie in der Activity Bar auf der linken Seite des Fensters auf das Symbol Extensions.

    Extensions icon in the Activity Bar in Visual Studio Code

    (Wenn die Activity Bar nicht angezeigt wird, stellen Sie sicher, dass View » Appearance » Show Activity Bar aktiviert ist).

    Dadurch wird die Extensions-Ansicht angezeigt, in der Sie Erweiterungen aus dem Marketplace für Erweiterungen durchsuchen und installieren können.

  2. Suchen Sie im Suchfeld für Search Extensions in Marketplace nach folgendem Begriff:

    metals
    
  3. Suchen Sie in den Suchergebnissen die Erweiterung „Scala (Metals)“, und klicken Sie auf Install.

Weitere Informationen zur „Scala (Metals)“-Erweiterung finden Sie in der Metals-Dokumentation unter Visual Studio Code.

Erstellen eines neuen Scala-Projekts in Visual Studio Code

Als Nächstes erstellen Sie ein neues Scala-Projekt für Snowpark.

  1. Erstellen Sie ein Arbeitsbereichsverzeichnis für Ihre Projekte. Beispiel:

    mkdir snowpark_projects
    

    Dieses Verzeichnis enthält Unterverzeichnisse für die Projekte, die Sie erstellen.

  2. Wählen Sie in Visual Studio Code unter File » Open das von Ihnen erstellte Verzeichnis aus, und klicken Sie auf Open.

  3. Klicken Sie in der Activity Bar auf der linken Seite auf das Metals-Symbol.

    Metals extension icon in the Activity Bar in Visual Studio Code
  4. Klicken Sie in der Side Bar (rechts neben der Activity Bar) unter Packages auf die Schaltfläche New Scala Project.

    Button to create a new Scala project Visual Studio Code
  5. Wählen Sie eine Vorlage aus, die für das neue Projekt verwendet werden soll (z. B. scala/hello-world.g8).

  6. Wählen Sie das Arbeitsbereichsverzeichnis aus, das Sie zuvor erstellt haben (snowpark_projects), und klicken Sie auf Ok.

  7. Geben Sie einen Namen für die das neue Projekt an (z. B. hello_snowpark).

  8. In der rechten unteren Ecke des Fensters wird ein Dialogfeld angezeigt. Klicken Sie hier auf Yes, um das neue Projekt in einem neuen Fenster zu öffnen.

    Dialog box prompting you to open the new project in a new window
  9. Wenn Sie in einem weiteren Dialogfeld in der rechten unteren Ecke des Fensters dazu aufgefordert werden, klicken Sie auf Import build, um den Build zu importieren.

    Dialog box prompting you to import the build for the new project

Konfigurieren des Visual Studio Code-Projekts für Snowpark

Als Nächstes konfigurieren Sie das Projekt für Snowpark.

  1. Stellen Sie sicher, dass in der Activity Bar auf der linken Seite des Fensters das Explorer-Symbol (das erste Symbol von oben) ausgewählt ist.

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Wählen Sie unter Explorer in der Side Bar (rechts neben der Activity Bar) unter Ihrem Projekt die Datei build.sbt zur Bearbeitung aus.

    Selecting the build.sbt file for editing

    Nehmen Sie in der build.sbt-Datei Ihres Projekts die folgenden Änderungen vor:

    1. Wenn die Einstellung scalaVersion nicht mit der Version übereinstimmt, die Sie verwenden möchten, aktualisieren Sie die Einstellung. Beispiel:

      scalaVersion := "2.12.13"
      

      Stellen Sie sicher, dass Sie eine Scala-Version verwenden, die für die Verwendung mit der Snowpark-Bibliothek unterstützt wird.

    2. Fügen Sie das OSGEO-Release-Repository zur Liste der Resolver und die Snowpark-Bibliothek zur Liste der Abhängigkeiten hinzu. Beispiel:

      resolvers += "OSGeo Release Repository" at "https://repo.osgeo.org/repository/release/"
      libraryDependencies += "com.snowflake" % "snowpark" % "0.8.0"
  3. Speichern Sie Ihre Änderungen mit File » Save.

  4. Wenn Sie vom Dialogfeld in der rechten unteren Ecke des Fensters dazu aufgefordert werden, klicken Sie auf Import changes, um die Datei erneut zu importieren.

    Dialog box prompting you to re-import the build.sbt file

Überprüfen der Konfiguration Ihres Visual Studio Code-Projekts

Um zu überprüfen, ob Sie Ihr Projekt für die Verwendung von Snowpark konfiguriert haben, führen Sie ein einfaches Beispiel mit Snowpark-Code aus.

  1. Stellen Sie sicher, dass in der Activity Bar auf der linken Seite des Fensters das Explorer-Symbol (das erste Symbol von oben) ausgewählt ist.

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Erweitern Sie unter Explorer in der Side Bar unter Ihrem Projekt den Ordner src/main/scala, und wählen Sie hier die Datei Main.scala zum Öffnen aus.

  3. Ersetzen Sie in der Datei Main.scala den Inhalt durch den unten stehenden Code:

    import com.snowflake.snowpark._
    import com.snowflake.snowpark.functions._
    
    object Main {
      def main(args: Array[String]): Unit = {
        // Replace the <placeholders> below.
        val configs = Map (
          "URL" -> "https://<account_identifier>.snowflakecomputing.com:443",
          "USER" -> "<user name>",
          "PASSWORD" -> "<password>",
          "ROLE" -> "<role name>",
          "WAREHOUSE" -> "<warehouse name>",
          "DB" -> "<database name>",
          "SCHEMA" -> "<schema name>"
        )
        val session = Session.builder.configs(configs).create
        session.sql("show tables").show()
      }
    }
    

    Beachten Sie Folgendes:

    • Ersetzen Sie die <Platzhalter> durch Werte, die Sie zur Verbindung mit Snowflake verwenden.

    • Geben Sie für <Kontobezeichner> Ihren Kontobezeichner an.

    • Bei Verwendung der Schlüsselpaar-Authentifizierung:

      • Ersetzen Sie PASSWORD durch PRIVATE_KEY_FILE, und geben Sie den Pfad zu Ihrer privaten Schlüsseldatei an.

      • Wenn der private Schlüssel verschlüsselt ist, müssen Sie für PRIVATE_KEY_FILE_PWD die Passphrase zum Entschlüsseln des privaten Schlüssels einstellen.

      Alternativ zur Einstellung von PRIVATE_KEY_FILE und PRIVATE_KEY_FILE_PWD können Sie für die Eigenschaft PRIVATEKEY den Zeichenfolgenwert des unverschlüsselten privaten Schlüssels aus der privaten Schlüsseldatei einstellen.

      • Wenn Ihre private Schlüsseldatei beispielsweise unverschlüsselt ist, setzen Sie diesen Wert auf den Wert des Schlüssels in der Datei (ohne die Kopf- und Fußzeilen -----BEGIN PRIVATE KEY----- und -----END PRIVATE KEY----- und ohne die Zeilenenden).

      • Beachten Sie, dass Sie bei einem verschlüsselten privaten Schlüssel erst den Schlüssel entschlüsseln müssen, bevor Sie ihn als Wert der Eigenschaft PRIVATEKEY festlegen.

    • Wenn Sie UDFs erstellen möchten:

  4. Klicken Sie zur Ausführung des Beispiels über der Object-Zeile auf run.

Falls die folgende Fehlermeldung angezeigt wird:

Run session not started

Prüfen Sie die Registerkarte Problems im unteren Teil des Fensters. Wenn diese Registerkarte nicht unten im Fenster angezeigt wird, wählen Sie im Menü die Option View > Problems aus.