Prerequisites for Snowpark

Scala

The Snowpark API is supported with Scala 2.12 (specifically, version 2.12.9 and later 2.12.x versions).

Note

Scala 2.13.x (a more recent version of Scala) is not supported.

If you use Scala 2.13.x, your code may fail to execute with java.lang.NoSuchMethodError and illegal cyclic inheritance involving trait Iterable / Map errors.

Java Virtual Machine (JVM) for Scala

For the JVM used with Scala, Java 11 is the recommended version.