Business Intelligence (BI)

Business intelligence (BI) tools enable analyzing, discovering, and reporting on data to help executives and managers make more informed business decisions. A key component of any BI tool is the ability to deliver data visualization through dashboards, charts, and other graphical output.

Business intelligence also sometimes overlaps with technologies such as data integration/transformation and advanced analytics; however, we’ve chosen to list these technologies separately in their own categories.

The following BI tools and technologies are known to provide native connectivity to Snowflake:

Solution

Version / Installation Requirements

Notes

Adobe Campaign

Adobe Campaign: 20.1 (or higher)

Snowflake: ODBC Driver — download from the Snowflake Client Repository

AtScale

AtScale: 7.4 (or higher)

Snowflake: No requirements

AWS QuickSight

AWS Quicksight: No requirements

Snowflake: No requirements

Chartio

Chartio: No requirements

Snowflake: No requirements

Domo

Available in Partner Connect

Domo: No requirements

Snowflake: No requirements

IBM Cognos

IBM Cognos: 11.0.5, 04‘16 (or higher)

Snowflake: No requirements

Tableau

Looker: No requirements

Snowflake: No requirements

Metabase

Metabase: No requirements

Snowflake: No requirements

Microsoft Power BI

Microsoft Power BI Cloud Service: On-premises Data Gateway July Update (or higher)

Snowflake: ODBC Driver — download from the Snowflake Client Repository

Microsoft Power BI

Microsoft Power BI Desktop:

Snowflake: ODBC Driver — download from the Snowflake Client Repository

MicroStrategy

Microstrategy: Secure Enterprise Platform 10.2 or 10.3 (or higher)

Snowflake: ODBC Driver — download from the Snowflake Client Repository

Mode Analytics

Mode Analytics: No requirements

Snowflake: No requirements

Oracle Analytics

Oracle Analytics Cloud: March 2019 (or higher)

Snowflake: No requirements

Oracle Analytics

Oracle Analytics Desktop: November 2019 (or higher)

Snowflake: No requirements

Pentaho

Pentaho Business Analytics:

  • Pentaho 8.3 (or higher): Snowflake plugin — download from the Pentaho Customer Portal (requires login)

  • Pentaho 8.2 (or lower): No Pentaho requirements, but some Snowflake requirements

Snowflake:

  • Pentaho 8.3 (or higher): No requirements

  • Pentaho 8.2 (or lower): . JDBC Driver — download from Maven . or . 3rd-party connector (PentahoSnowflakePlugin) — download from GitHub

Pyramid Analytics

Pyramid: 2018 (or higher)

Snowflake: No requirements

Qlik

Qlik Sense: No requirements

Snowflake: No requirements

Sigma Computing

Available in Partner Connect

Sigma Computing: No requirements

Snowflake: No requirements

SAP BusinessObjects

SAP BusinessObjects: 4.2 SP08 (or higher)

Snowflake: . ODBC Driver — download from the Snowflake Client Repository . or . JDBC Driver — download from Maven

Sisense

Available in Partner Connect

Sisense: No requirements

Snowflake: No requirements

Tableau

Tableau: Desktop/Server/Online 9.3 (or higher)

Snowflake: ODBC Driver — download from the Snowflake Client Repository

Tableau CRM

Tableau CRM: No requirements

Snowflake: No requirements

ThoughtSpot

Available in Partner Connect

Thoughtspot: No requirements

Snowflake: No requirements

TIBCO Spotfire

Tibco Spotfire: 10.3 LTS (or higher)

Snowflake: ODBC Driver — download from the Snowflake Client Repository