Snowpark用Visual Studio Codeの設定

このトピックでは、Snowpark用Visual Studio Codeを設定する方法について説明します。

このトピックの内容:

Scala開発用Visual Studio Codeの設定

Visual Studio CodeでScalaコードを作成するときに便利なように、 Metals拡張機能 をインストールします。Metals拡張機能は、コード補完、パラメーターヒント、および型とメソッドに関する情報を提供します。

Metals拡張機能をインストールするには、

  1. ウィンドウの左側 にある Activity Bar で、 Extensions アイコンをクリックします。

    Extensions icon in the Activity Bar in Visual Studio Code

    Activity Bar が表示されない場合は、 View » Appearance » Show Activity Bar がチェックされていることを確認。)

    これにより、 Extensions ビューが表示され、Extensions Marketplaceから拡張機能を参照してインストールできます。

  2. Search Extensions in Marketplace の検索ボックスで、次の用語を検索します。

    metals
    
  3. 検索結果で、Scala(Metals)拡張機能を見つけて、 Install をクリックします。

Scala(Metals)拡張機能の詳細については、 MetalsドキュメントVisual Studio Code をご参照ください。

Visual Studio Codeでの新しいScalaプロジェクトの作成

次に、Snowpark用の新しいScalaプロジェクトを作成します。

  1. プロジェクトのワークスペースディレクトリを作成します。例:

    mkdir snowpark_projects
    

    このディレクトリには、作成したプロジェクトのサブディレクトリが含まれます。

  2. Visual Studio Codeで、 File » Open を選択し、作成したディレクトリを選択して、 Open をクリックします。

  3. 左側の Activity Bar で、 Metals アイコンをクリックします。

    Metals extension icon in the Activity Bar in Visual Studio Code
  4. Side BarPackagesActivity Bar右側)の下にある New Scala Project ボタンをクリックします。

    Button to create a new Scala project Visual Studio Code
  5. 新しいプロジェクトに使用するテンプレートを選択します(例: scala/hello-world.g8)。

  6. 以前に作成したワークスペースディレクトリ(snowpark_projects)を選択し、 Ok をクリックします。

  7. 新しいプロジェクトの名前を入力します(例: hello_snowpark)。

  8. ウィンドウの右下隅にあるダイアログボックスでプロンプトが表示されたら、 Yes をクリックして新しいプロジェクトを新しいウィンドウで開きます。

    Dialog box prompting you to open the new project in a new window
  9. ウィンドウの右下隅にあるダイアログボックスでプロンプトが表示されたら、 Import build をクリックして ビルドをインポート します。

    Dialog box prompting you to import the build for the new project

Snowpark用Visual Studio Codeプロジェクトの構成

次に、Snowpark用プロジェクトを構成します。

  1. ウィンドウの左側Activity Bar で、 Explorer アイコン(上部にある最初のアイコン)が選択されていることを確認します。

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Side Bar の:extui:ExplorerActivity Bar右側)の下、プロジェクトの下で、編集する build.sbt ファイルを選択します。

    Selecting the build.sbt file for editing

    プロジェクトの build.sbt ファイルで、次を変更します。

    1. scalaVersion 設定が使用する予定のバージョンと一致しない場合は、設定を更新します。例:

      scalaVersion := "2.12.13"
      

      Snowparkライブラリとの使用がサポートされているScalaバージョン を使用する必要があることに注意してください。

    2. OSGEO リリースリポジトリをリゾルバーのリストに追加し、Snowparkライブラリを依存関係のリストに追加します。例:

      resolvers += "OSGeo Release Repository" at "https://repo.osgeo.org/repository/release/"
      libraryDependencies += "com.snowflake" % "snowpark" % "0.8.0"
  3. これらの変更を行った後、 File » Save を選択して変更を保存します。

  4. ウィンドウの右下隅にあるダイアログボックスでプロンプトが表示されたら、 Import changes をクリックして ファイルを再インポート します。

    Dialog box prompting you to re-import the build.sbt file

Visual Studio Codeプロジェクト構成の確認

Snowparkを使用するようにプロジェクトを構成したことを確認するには、Snowparkコードの簡単な例を実行します。

  1. ウィンドウの左側Activity Bar で、 Explorer アイコン(上部にある最初のアイコン)が選択されていることを確認します。

    Explorer icon selected in the Activity Bar in Visual Studio Code
  2. Side BarExplorer の下、プロジェクトの下で、 src/main/scala フォルダーを展開し、 Main.scala ファイルを選択して開きます。

  3. Main.scala ファイルで、内容を次のコードに置き換えます。

    import com.snowflake.snowpark._
    import com.snowflake.snowpark.functions._
    
    object Main {
      def main(args: Array[String]): Unit = {
        // Replace the <placeholders> below.
        val configs = Map (
          "URL" -> "https://<account_identifier>.snowflakecomputing.com:443",
          "USER" -> "<user name>",
          "PASSWORD" -> "<password>",
          "ROLE" -> "<role name>",
          "WAREHOUSE" -> "<warehouse name>",
          "DB" -> "<database name>",
          "SCHEMA" -> "<schema name>"
        )
        val session = Session.builder.configs(configs).create
        session.sql("show tables").show()
      }
    }
    

    次の点に注意してください。

    • <プレースホルダー> をSnowflakeへの接続に使用する値に置き換えます。

    • <アカウント識別子> には、使用する アカウント識別子 を指定します。

    • キーペア認証 を使用する場合は、

      • PASSWORDPRIVATE_KEY_FILE に置き換え、秘密キーファイルへのパスに設定します。

      • 秘密キーが暗号化されている場合は、秘密キーを復号化するためのパスフレーズに PRIVATE_KEY_FILE_PWD を設定する必要があります。

      PRIVATE_KEY_FILEPRIVATE_KEY_FILE_PWD を設定する代わりに、 PRIVATEKEY プロパティを秘密キーファイルからの 暗号化されていない 秘密キーの文字列値に設定できます。

      • たとえば、秘密キーファイルが暗号化されていない場合は、これをファイル内のキーの値に設定します(-----BEGIN PRIVATE KEY----------END PRIVATE KEY----- ヘッダーとフッターなし、行末なし)。

      • 秘密キーが暗号化されている場合は、 PRIVATEKEY プロパティの値として設定する前に、キーを復号化する必要があることに注意してください。

    • UDFs を作成する場合は、

  4. Object 行の上にある run をクリックして、例を実行します。

次のエラーメッセージが表示された場合は、

Run session not started

ウィンドウの下部にある Problems タブを確認します。このタブがウィンドウの下部に表示されない場合は、メニューから View > Problems 項目を選択します。